💰>>>>>>>> Make A Donation <<<<<<<<💰

Station-Drivers only receives 50% of advertising revenue and the rest from donations to finance the operation of S-D, I internally thank some who regularly give me €1, €2, €5, €10,..., to be able to continue. A big thank you to those who give me regularly like 😉: Filippo-F, Ansley-B, Thierry-L, Jesus-F, Petr-H, Dionysios-S, Andreas-M, Amrit-L, Adrianus-L, Yunlun-T, Marlon-B, Xavier-M, Huang-X, ....
This allows me to continue my passion and be able to share it with you allFdrsoft 


Information! With the donations made, Station-Drivers will migrate to a new, more powerful server in early August 2024 to resolve the site's slowdown problems (J-11).

ssd Question NVME USB drives Realtek RTL9210/RTL9220 Firmware Version 1.xx

Réponse de symbios24 sur le sujet NVME USB drives Realtek RTL9210/RTL9220 Firmware Version 1.xx

Posted il y a 4 mois 3 semaines #2485
Hello

I have an rtl9201r sata controller case


Using a HDD to boot in my raspberry pi 4 and an external power supply for the hard drive.
The main problem I have is upon rebooting the OS the hard drive closes and opens again while on other cases I have with different chipsets I does not do this.it stay open even in shutdown.
I can update the config file of the chipset,as I did before to disable the sleep mode after 10 minutes,but I don't know what setting to add/change or remove to disable the power off at reboot/shutdown, I will appreciate any help about this

my config file contents are that downU2PHY : n/aU3PHY : n/aVID : 0x0bdaPID : 0x9201MANUFACTURE : "Realtek"PRODUCT : "RTL9201"SERIAL : "012345678999"SCSI_PRODUCT : "n/a "SCSI_VENDOR : "n/a "USB_SELF_PWR : n/aDISK_HOTPLUG : n/aLED : 0x03PINMUX1 : n/aPINMUX2 : n/aU2_MAXPWR : n/aU3_MAXPWR : n/aASPMDIS : n/aPCIE_REFCLK : n/aDISK_IPS_THRES : n/aSWR_1_2V : n/aEN_UPS : n/aPD : n/aCUSTOMIZED_LED : 08 00 00 00 00 00 00 00 00 00 00 00 00 00 00SUSPEND_LED_OFF : n/aFORCE_USB_SPEED : n/aFORCE_PCIE_SPEED : n/aEN_U1U2 : n/aFORCE_USB_QUIRK : n/aFORCE_PCIE_QUIRK : n/aFAN : n/aDIS_SHOW_EMPTY_DISK : n/aFORCE_SATA_NORMAL_DMA : n/aUART_DBG_PIN : 0x64FINGER_PRINT_EN : n/aRM_INTERNAL_RD : n/aHS_AUTO_SWITCH : n/aUART_BAUD_RATE : 0x00000000CUSTOMIZED_DISK_IDENTIFY : n/aHW_LED_CFG : n/aCDROM_CFG : n/aSUPPORT_HID : n/aLATE_INIT_DISK : n/aSCSI_WP_PIN : n/aSD_MMC_TYPE : n/aFORCE_PORT_TYPE : n/aBCDDEVICE : n/aSUSPEND_DISK_OFF : n/aSCSI_WB_PIN : n/aCUSTOMIZED_FEATURE : n/aPERIPH_API : 0x00RAID_CFG : n/aBoot Mode : FlashFW Ver : 1.32.7FW Build Date : 2022.11.25IC Pkg Type : SATAUUID : n/aWhat do I change to disable the hard drive turn-off function on reboot or shutdown?

Thanks 
Last Edit:il y a 4 mois 3 semaines par symbios24
Dernière édition: il y a 4 mois 3 semaines par symbios24.

Connexion ou Créer un compte pour participer à la conversation.

Réponse de Laroldski sur le sujet NVME USB drives Realtek RTL9210/RTL9220 Firmware Version 1.xx

Posted il y a 4 mois 1 semaine #2539
Hi everyone I just wanted to say hello and ask a question.

I had been coming to this forum about a year ago and never joined and just checked out what was new and stuff within the forum,what I was wondering is if anyone can tell me what's the latest firmware for the RTL9210 controller,the reason I'm asking here is because when I came here before I seen that sometimes the firmware would be posted in the forum and would be newer but not always posted on the main site where the firmware is posted normally.
par Laroldski

Connexion ou Créer un compte pour participer à la conversation.

  • admin
  • Portrait de admin Hors Ligne Auteur du sujet
  • Admin
  • Admin
    Administrateur
  • Messages : 576
  • Thanks: 270

Réponse de admin sur le sujet NVME USB drives Realtek RTL9210/RTL9220 Firmware Version 1.xx

Posted il y a 4 mois 1 semaine #2541
hi the latest ones still appeared on the News page and we talk about our experience on the Forum


Configuration
Asus Z790 Pro Art, Intel Cpu I7 14700K, Memoires 32Go Corsair DDR5 (6000Mhz CL30), Water-cooling Thermaright, nVidia Geforce RTX3060,  Alimentation Asus ROG 850W, Samsung SSD 990 Pro, SSD980 Pro, Clavier Roccat Vulkan , Souris Asus, Boitier NZXT H6, HP Creative SB Kratos Free Fibre 10Gb Cable CAT8/7, Switch 10/5/2.5Gbps, Casque Philips Fedelis.

par admin

Connexion ou Créer un compte pour participer à la conversation.

Réponse de JustATester sur le sujet NVME USB drives Realtek RTL9210/RTL9220 Firmware Version 1.xx

Posted il y a 4 mois 1 semaine #2552
I recently got a UnionSine NVME Enclosure, it's supposed to support USB 3.2 Gen 2x2 20Gbps (though I have no way of verifying this, as my PC supports a maximum of 10Gbps).
MPtool Lite shows it as having a RTL9220-VBB-CG, it's possible I missed it, but as of yet I haven't seen any other enclosures using this IC.

 

When connected to a 10Gbps USB port under Windows, it shows as SuperSpeed Plus (10Gbps) just fine (verified using both MPtool Lite and HWinfo)
Under Linux however it always shows as 5Gbps. Do you think it's possible this would be caused by firmware giving the wrong information?

I've dumped the config for anyone interested:
Attention : Spoiler !

---
PC Config: AMD Ryzen 5800X3D, B550 AORUS ELITE AX V2 (rev. 1.1), 64GB RAM, Samsung 980 Pro 2TB, Samsung 980 1TB, HGST 4TB x3.

Last Edit:il y a 4 mois 1 semaine par JustATester
Dernière édition: il y a 4 mois 1 semaine par JustATester.

Connexion ou Créer un compte pour participer à la conversation.

Réponse de Laroldski sur le sujet NVME USB drives Realtek RTL9210/RTL9220 Firmware Version 1.xx

Posted il y a 4 mois 1 semaine #2553

I recently got a UnionSine NVME Enclosure, it's supposed to support USB 3.2 Gen 2x2 20Gbps (though I have no way of verifying this, as my PC supports a maximum of 10Gbps).
MPtool Lite shows it as having a RTL9220-VBB-CG, it's possible I missed it, but as of yet I haven't seen any other enclosures using this IC.

 

When connected to a 10Gbps USB port under Windows, it shows as SuperSpeed Plus (10Gbps) just fine (verified using both MPtool Lite and HWinfo)
Under Linux however it always shows as 5Gbps. Do you think it's possible this would be caused by firmware giving the wrong information?

I've dumped the config for anyone interested:
Attention : Spoiler !


Which Unionsine enclosure do you have,they sell 2 that look almost the same and the other is called Hiksemi and people get them mixed up,I own both that way I have 2 different looking enclosure's because I need a lot of portable storage space.

If you want the original configure file for the Unionsine and Hiksemi enclosure's linked I can email them to you if you want,I know they both have boards that are a bit different and they each use a different configure file,I know the Unionsine's that I got were still using the old version of the board with the last's ones I got and the led light won't work right if the wrong configure file isn't used.

I noticed as well that when I flashed my RTL9210 controllers with new firmware it would say Golden onetime and something else the next and still perform at the same speed,I have updated mine about 4 or 5 times as the newer firmware came out.

www.aliexpress.com/item/1005005057195255...arch%7Cquery_from%3A









 
Last Edit:il y a 4 mois 1 semaine par Laroldski
Dernière édition: il y a 4 mois 1 semaine par Laroldski.

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 1.464 secondes
Propulsé par Kunena