ssd Question NVME USB drives Realtek RTL9210/RTL9220 Firmware Version 1.xx

Replied by ikerrg on topic NVME USB drives Realtek RTL9210/RTL9220 Firmware Version 1.xx

Posted 6 months 4 weeks ago #2016
Hello,

Some time ago I was able to update the firmware of my RTL9210B enclosure to 1.32.16. However, I have not been able to go further (e.g. 1.32.87), as it always fails the update process. I noticed that the golden firmware version (the 68 kB file) has jumped from 1.xx to 4.xx, which might explain the incompatibility with my enclosure. Anybody has any idea about why this could be happening?

Thanks!

Never mind, I think I found the problem. I forgot to remove the M.2 drive from the enclosure. It was a long time ago when I did the last update and I did not remember that I had to do that.

 
Last Edit:6 months 4 weeks ago by ikerrg
Last edit: 6 months 4 weeks ago by ikerrg.
The following user(s) said Thank You: admin

Please Log in or Create an account to join the conversation.

Hello all, I have a problem with my Inland Premium Enclosure (9120B)

PROBLEM: Starts at 300 mb/s, then slows to 40 mb/s after ~10-30 gigabytes when COPYING FROM the enclosure. ***The limiting factor is the enclosure itself, see the attached photos

SYSTEM: Transfer FROM crucial P3 TO samsung 990 pro. Firmware updater registers super plus speed. Single large iso transfer. No Other peripherals but integrated laptop peripheral connected. 

TROUBLESHOOTING: I have tried nearly every firmware update on this page using the stock 9120b configuration that comes with most of the files. I have also tried the SSK and orico configurations as well. 

From the photos, it is definitely the enclosure that is the problem, not the computer itself. The connection is fine and it is registering at least 300 mb/s of sustained transfer before it slows down. This occurs on other computers, as well as while transferring to a non-shingled hdd that has 250 mb/s sustained write. I for the life of me cannot figure out why the enclosure is slowing down like this. 

Nothing is excessively hot. I unfortunately do not have the original configuration for the enclosure. Any help would be amazing. 

The enclosure came with 1.29 BTW, I have tried flashing everything from 1.17 to 1.32 on the enclosure.
 

Please Log in or Create an account to join the conversation.

  • admin
  • admin's Avatar Offline Topic Author
  • Admin
  • Admin
    Administrateur
  • Posts: 562
  • Thanks: 258

Replied by admin on topic NVME USB drives Realtek RTL9210/RTL9220 Firmware Version 1.xx

Posted 6 months 2 weeks ago #2070
Hi,
The problem can be multiple such as the supplied USB cable which is of poor quality, the PC's USB drivers to be updated if necessary.
put your PC on performance instead of saving because this also affects the performance of the USB ports
Here but performance with AN RTL9210 on my Asus TUF

 

   

 



 


Configuration
Asus Z790 Pro Art, Intel Cpu I7 14700K, Memoires 32Go Corsair DDR5 (6000Mhz CL30), Water-cooling Thermaright, nVidia Geforce RTX3060,  Alimentation Asus ROG 850W, Samsung SSD 990 Pro, SSD980 Pro, Clavier Roccat Vulkan , Souris Asus, Boitier NZXT H6, HP Creative SB Kratos Free Fibre 10Gb Cable CAT8/7, Switch 10/5/2.5Gbps, Casque Philips Fedelis.

Last Edit:6 months 2 weeks ago by admin
Last edit: 6 months 2 weeks ago by admin.

Please Log in or Create an account to join the conversation.

Hi there and thank you for the reply. I just went to microcenter to exchange the enclosure for a new one, and I'm finding the same exact issue on a non-firmware updated enclosure. I am using a cable analogous to this one.  It is a flexible PCB cable that should have the least amount of resistance. 

If I use teracopy, which limits the speed at which the drive can transfer to ~240 mb/s, it doesn't have the slowdown issue. If I let windows go full speed on the transfer, I end up with the same problem.

The attached image is the stock firmware and settings from the update tool. I also have now saved the configuration.

Please Log in or Create an account to join the conversation.

I noticed that you are using multiple files present. What happens if you try and transfer a single 40+ gb file on your drive? Does it slow down?

Please Log in or Create an account to join the conversation.

Time to create page: 0.655 seconds
Powered by Kunena Forum